View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001333OpenFOAM[All Projects] Bugpublic2014-06-27 10:162014-07-01 09:03
ReporterRygelXVI 
Assigned Tohenry 
PrioritylowSeverityminorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformUnixOSOtherOS Version(please specify)
Product Version2.3.x 
Target VersionFixed in Version 
Summary0001333: FoamQuadMesh missing build file?
DescriptionInstall built etc version: 2.3.x-ddafa9836ad9
On Ubuntu 12.04

Copy /home/thenamelessone/OpenFOAM/OpenFOAM-2.3.x/tutorials/mesh/foamyQuadMesh/square
to ~/OpenFOAM/thenamelessone-2.3.x/tutorials

cd to that location and attempt ./Allrun
the log.foamQuad... says: './Allrun: 52: ./Allrun: foamyQuadMesh: not found'
So I tried to see if it was just me not having built things properly by going back to /OpenFOAM/OpenFOAM-2.3.x and running Allwmake again, everything was apparently up to date. So I manually went into /home/thenamelessone/OpenFOAM/OpenFOAM-2.3.x/applications/utilities/mesh/generation/foamyQuadMesh
and tried a local ./Allwmake which also returned an error (see attached log).

Im guessing something is missing from a ./allmake or similar somewhere but didn't look into it further.
Steps To ReproduceFor install of OF 2.3.x-ddafa9836ad9
cd to
.../tutorials/mesh/foamyQuadMesh/square
try to run ./Allrun
see error
TagsNo tags attached.
Attached Files? file icon logError [^] (1,836 bytes) 2014-06-27 10:16 [Show Content]

- Relationships

-  Notes
(0003141)
wyldckat (reporter)
2014-06-28 20:46

The log file "logError" you've provided does not provide any error message... are you certain it's complete?

And few questions:
1. Which installation instructions did you follow?
2. How was CGAL built/installed?


Either way, try the following commands:

  cd "$FOAM_UTILITIES/mesh/generation"
  ./Allwmake > log.make 2>&1

Then check the contents of the file "log.make" to see what error messages it gives you. If you can't understand the problem from it, please attach it to this bug report.


Side note: This does seem related to a bug report I made sometime ago, namely #1186: http://www.openfoam.org/mantisbt/view.php?id=1186 [^]
(0003145)
RygelXVI (reporter)
2014-07-01 08:47

My appologies, the missing lines from the error log are:

In file included from GCALTriangulation2Ddefs.H:44:0,
from CV2D.H:120,
from CV2D.C:26:
CGALTriangulation2DKernel.H:36:43 fatal error GCAL/Delaunay_triangulation_2.h: No such file or directory compilation terminated.

I was following the git repository release instructions. But it appears to have been my mistake; I didn't notice the new extra package dependencies. (I assumed it was the same since my last build.) Rebuilding after apt-getting gcal fixed all. Sorry for the erroneous report.

- Issue History
Date Modified Username Field Change
2014-06-27 10:16 RygelXVI New Issue
2014-06-27 10:16 RygelXVI File Added: logError
2014-06-28 20:46 wyldckat Note Added: 0003141
2014-07-01 08:47 RygelXVI Note Added: 0003145
2014-07-01 08:59 henry Status new => closed
2014-07-01 09:03 henry Assigned To => henry
2014-07-01 09:03 henry Resolution open => no change required