View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000584OpenFOAM[All Projects] Bugpublic2012-07-15 11:102013-03-14 09:00
Reporterlinnemann 
Assigned Tol_r_mcglashan 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformCentOSOSx86_64OS Version6.3
Product Version2.1.x 
Target VersionFixed in Version 
Summary0000584: Salome platforms UNV format in 6.5.0 does not work with ideasUnvToFoam
DescriptionMake a simple mesh in Salome export to UNV and use ideasUnvToFoam on the mesh results is the following output and empty mesh files.

/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.1.1-221db2718bbb
Exec : ideasUnvToFoam Mesh_1.unv
Date : Jul 15 2012
Time : 12:07:12
Host : "desktop.aaui.dk"
PID : 6404
Case : /home/linnemann/OF-cases/para-pipe
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Sorting boundary faces according to group (patch)

Constructing mesh with non-default patches of size:

End
Additional InformationUse the attached .py file in Salome to generate a relatively simple pipe mesh.
TagsNo tags attached.
Attached Files? file icon parabolicDump.py [^] (12,459 bytes) 2012-07-15 11:10

- Relationships

-  Notes
(0001463)
l_r_mcglashan (reporter)
2012-07-16 11:44

The second line of the generated .unv file is not 6 columns wide:

   164

Change that and ideasUnvToFoam runs. The problem is with Salome's .unv output.

- Issue History
Date Modified Username Field Change
2012-07-15 11:10 linnemann New Issue
2012-07-15 11:10 linnemann File Added: parabolicDump.py
2012-07-16 11:44 l_r_mcglashan Note Added: 0001463
2012-07-16 11:45 l_r_mcglashan Status new => closed
2012-07-16 11:45 l_r_mcglashan Assigned To => l_r_mcglashan
2012-07-16 11:45 l_r_mcglashan Resolution open => no change required
2013-03-14 09:00 mattijs Status closed => resolved